MacOSX mojave(10.14)에서 어플리케이션 빌드를 하기 위해 설정을 해야했음.

checking what macOS SDK to use... configure: error: Could not find an appropriate macOS SDK

Mac위의 메세지가 뜨면서 빌드 설정이 실패시 아래의 명령어를 입력하여 macOS SDK를 설치하면 된다.

이번에 나온 MacOSX mojave(10.14) 부터 헤더파일(headers)이 `/usr/include/`에 기본적으로 설치되지 않습니다.

그래서 헤더파일(header)파일을 설치하려면 아래의 명령어를 입력하여

$ open /Library/Developer/CommandLineTools/Packages/macOS\_SDK\_headers\_for\_macOS\_10.14.pkg

를 실행합니다.

실행이 완료되면 아래의 설치화면이 뜹니다.

설치가 완료되면 어플리케이션 빌드가 가능합니다.

+ Recent posts